Technical Requirements

In order to successfully navigate your online course in Moodle 2.9, you may utilize the minimum versions of any of the browsers listed below.

  • Google Chrome 30.0
  • Mozilla Firefox 25.0
  • Apple Safari 6
  • Microsoft Internet Explorer 9

Moodle recommends the latest version of any of the browsers listed above, but the minimum version identified will be sufficient for accessing your course.

You may also be accessing a variety of types of files throughout your course enrollment. It is recommended that you have the ability to open and view PDF files and Word documents and have a media player installed on your computer so that you can view video clips.


Last modified: Thursday, July 9, 2015, 9:00 AM